Acousto Aws

ps-MacBook-Air:Downloads pi$ ssh -v -i ./EC2_free_keypair.pem moc.swanozama.etupmoc.2-tsew-su.171-521-002-45-2ce|utnubu#moc.swanozama.etupmoc.2-tsew-su.171-521-002-45-2ce|utnubu
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: Connecting to ec2-54-200-125-171.us-west-2.compute.amazonaws.com [54.200.125.171] port 22.
debug1: Connection established.
debug1: identity file ./EC2_free_keypair.pem type -1
debug1: identity file ./EC2_free_keypair.pem-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.2p2 Ubuntu-6
debug1: match: OpenSSH_6.2p2 Ubuntu-6 pat OpenSSH*
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr moc.hssnepo|mte-5dm-camh#moc.hssnepo|mte-5dm-camh none
debug1: kex: client->server aes128-ctr moc.hssnepo|mte-5dm-camh#moc.hssnepo|mte-5dm-camh none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 50:e9:28:85:ff:5b:7f:ef:15:d8:02:35:e9:11:13:84
The authenticity of host 'ec2-54-200-125-171.us-west-2.compute.amazonaws.com (54.200.125.171)' can't be established.
RSA key fingerprint is 50:e9:28:85:ff:5b:7f:ef:15:d8:02:35:e9:11:13:84.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'ec2-54-200-125-171.us-west-2.compute.amazonaws.com,54.200.125.171' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: ./EC2_free_keypair.pem
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
Authenticated to ec2-54-200-125-171.us-west-2.compute.amazonaws.com ([54.200.125.171]:22).
debug1: channel 0: new [client-session]
debug1: Requesting moc.hssnepo|snoisses-erom-on#moc.hssnepo|snoisses-erom-on
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_GB.UTF-8

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

ubuntu@ip-172-31-43-203:~$ sudo apt-get install gfortran
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
binutils cpp cpp-4.8 gcc gcc-4.8 gfortran-4.8 libasan0 libatomic1
libc-dev-bin libc6-dev libcloog-isl4 libgcc-4.8-dev libgfortran-4.8-dev
libgfortran3 libgmp10 libgomp1 libisl10 libitm1 libmpc3 libmpfr4
libquadmath0 libtsan0 linux-libc-dev manpages-dev
Suggested packages:
binutils-doc cpp-doc gcc-4.8-locales gcc-multilib make autoconf automake1.9
libtool flex bison gdb gcc-doc gcc-4.8-multilib libmudflap0-4.8-dev
gcc-4.8-doc libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan0-dbg
libtsan0-dbg libbacktrace1-dbg libquadmath0-dbg libmudflap0-dbg
binutils-gold gfortran-multilib gfortran-doc gfortran-4.8-multilib
gfortran-4.8-doc libgfortran3-dbg glibc-doc
The following NEW packages will be installed:
binutils cpp cpp-4.8 gcc gcc-4.8 gfortran gfortran-4.8 libasan0 libatomic1
libc-dev-bin libc6-dev libcloog-isl4 libgcc-4.8-dev libgfortran-4.8-dev
libgfortran3 libgmp10 libgomp1 libisl10 libitm1 libmpc3 libmpfr4
libquadmath0 libtsan0 linux-libc-dev manpages-dev
0 upgraded, 25 newly installed, 0 to remove and 0 not upgraded.
Need to get 33.2 MB of archives.
After this operation, 89.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libasan0 amd64 4.8.1-10ubuntu8 [75.8 kB]
Get:2 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libatomic1 amd64 4.8.1-10ubuntu8 [10.3 kB]
Get:3 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libgmp10 amd64 2:5.1.2+dfsg-2ubuntu1 [252 kB]
Get:4 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libisl10 amd64 0.11.2-1 [487 kB]
Get:5 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libcloog-isl4 amd64 0.18.0-2 [67.9 kB]
Get:6 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libquadmath0 amd64 4.8.1-10ubuntu8 [139 kB]
Get:7 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libgfortran3 amd64 4.8.1-10ubuntu8 [346 kB]
Get:8 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libgomp1 amd64 4.8.1-10ubuntu8 [27.0 kB]
Get:9 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libitm1 amd64 4.8.1-10ubuntu8 [37.4 kB]
Get:10 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libmpfr4 amd64 3.1.1-2 [202 kB]
Get:11 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libtsan0 amd64 4.8.1-10ubuntu8 [118 kB]
Get:12 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libmpc3 amd64 1.0.1-1 [45.0 kB]
Get:13 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main binutils amd64 2.23.52.20130913-0ubuntu1 [3,593 kB]
Get:14 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main cpp-4.8 amd64 4.8.1-10ubuntu8 [5,838 kB]
Get:15 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main cpp amd64 4:4.8.1-2ubuntu3 [28.0 kB]
Get:16 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libgcc-4.8-dev amd64 4.8.1-10ubuntu8 [2,792 kB]
Get:17 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main gcc-4.8 amd64 4.8.1-10ubuntu8 [6,636 kB]
Get:18 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main gcc amd64 4:4.8.1-2ubuntu3 [5,128 B]
Get:19 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libgfortran-4.8-dev amd64 4.8.1-10ubuntu8 [438 kB]
Get:20 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libc-dev-bin amd64 2.17-93ubuntu4 [80.9 kB]
Get:21 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main linux-libc-dev amd64 3.11.0-12.19 [945 kB]
Get:22 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libc6-dev amd64 2.17-93ubuntu4 [3,091 kB]
Get:23 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main gfortran-4.8 amd64 4.8.1-10ubuntu8 [6,173 kB]
Get:24 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main gfortran amd64 4:4.8.1-2ubuntu3 [1,208 B]
Get:25 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main manpages-dev all 3.54-1ubuntu1 [1,820 kB]
Fetched 33.2 MB in 2s (11.1 MB/s)
Selecting previously unselected package libasan0:amd64.
(Reading database … 53345 files and directories currently installed.)
Unpacking libasan0:amd64 (from …/libasan0_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libatomic1:amd64.
Unpacking libatomic1:amd64 (from …/libatomic1_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libgmp10:amd64.
Unpacking libgmp10:amd64 (from …/libgmp10_2%3a5.1.2+dfsg-2ubuntu1_amd64.deb) …
Selecting previously unselected package libisl10:amd64.
Unpacking libisl10:amd64 (from …/libisl10_0.11.2-1_amd64.deb) …
Selecting previously unselected package libcloog-isl4:amd64.
Unpacking libcloog-isl4:amd64 (from …/libcloog-isl4_0.18.0-2_amd64.deb) …
Selecting previously unselected package libquadmath0:amd64.
Unpacking libquadmath0:amd64 (from …/libquadmath0_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libgfortran3:amd64.
Unpacking libgfortran3:amd64 (from …/libgfortran3_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libgomp1:amd64.
Unpacking libgomp1:amd64 (from …/libgomp1_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libitm1:amd64.
Unpacking libitm1:amd64 (from …/libitm1_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libmpfr4:amd64.
Unpacking libmpfr4:amd64 (from …/libmpfr4_3.1.1-2_amd64.deb) …
Selecting previously unselected package libtsan0:amd64.
Unpacking libtsan0:amd64 (from …/libtsan0_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libmpc3:amd64.
Unpacking libmpc3:amd64 (from …/libmpc3_1.0.1-1_amd64.deb) …
Selecting previously unselected package binutils.
Unpacking binutils (from …/binutils_2.23.52.20130913-0ubuntu1_amd64.deb) …
Selecting previously unselected package cpp-4.8.
Unpacking cpp-4.8 (from …/cpp-4.8_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package cpp.
Unpacking cpp (from …/cpp_4%3a4.8.1-2ubuntu3_amd64.deb) …
Selecting previously unselected package libgcc-4.8-dev:amd64.
Unpacking libgcc-4.8-dev:amd64 (from …/libgcc-4.8-dev_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package gcc-4.8.
Unpacking gcc-4.8 (from …/gcc-4.8_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package gcc.
Unpacking gcc (from …/gcc_4%3a4.8.1-2ubuntu3_amd64.deb) …
Selecting previously unselected package libgfortran-4.8-dev:amd64.
Unpacking libgfortran-4.8-dev:amd64 (from …/libgfortran-4.8-dev_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package libc-dev-bin.
Unpacking libc-dev-bin (from …/libc-dev-bin_2.17-93ubuntu4_amd64.deb) …
Selecting previously unselected package linux-libc-dev:amd64.
Unpacking linux-libc-dev:amd64 (from …/linux-libc-dev_3.11.0-12.19_amd64.deb) …
Selecting previously unselected package libc6-dev:amd64.
Unpacking libc6-dev:amd64 (from …/libc6-dev_2.17-93ubuntu4_amd64.deb) …
Selecting previously unselected package gfortran-4.8.
Unpacking gfortran-4.8 (from …/gfortran-4.8_4.8.1-10ubuntu8_amd64.deb) …
Selecting previously unselected package gfortran.
Unpacking gfortran (from …/gfortran_4%3a4.8.1-2ubuntu3_amd64.deb) …
Selecting previously unselected package manpages-dev.
Unpacking manpages-dev (from …/manpages-dev_3.54-1ubuntu1_all.deb) …
Processing triggers for man-db …
Setting up libasan0:amd64 (4.8.1-10ubuntu8) …
Setting up libatomic1:amd64 (4.8.1-10ubuntu8) …
Setting up libgmp10:amd64 (2:5.1.2+dfsg-2ubuntu1) …
Setting up libisl10:amd64 (0.11.2-1) …
Setting up libcloog-isl4:amd64 (0.18.0-2) …
Setting up libquadmath0:amd64 (4.8.1-10ubuntu8) …
Setting up libgfortran3:amd64 (4.8.1-10ubuntu8) …
Setting up libgomp1:amd64 (4.8.1-10ubuntu8) …
Setting up libitm1:amd64 (4.8.1-10ubuntu8) …
Setting up libmpfr4:amd64 (3.1.1-2) …
Setting up libtsan0:amd64 (4.8.1-10ubuntu8) …
Setting up libmpc3:amd64 (1.0.1-1) …
Setting up binutils (2.23.52.20130913-0ubuntu1) …
Setting up cpp-4.8 (4.8.1-10ubuntu8) …
Setting up cpp (4:4.8.1-2ubuntu3) …
Setting up libgcc-4.8-dev:amd64 (4.8.1-10ubuntu8) …
Setting up gcc-4.8 (4.8.1-10ubuntu8) …
Setting up gcc (4:4.8.1-2ubuntu3) …
Setting up libgfortran-4.8-dev:amd64 (4.8.1-10ubuntu8) …
Setting up libc-dev-bin (2.17-93ubuntu4) …
Setting up linux-libc-dev:amd64 (3.11.0-12.19) …
Setting up libc6-dev:amd64 (2.17-93ubuntu4) …
Setting up gfortran-4.8 (4.8.1-10ubuntu8) …
Setting up gfortran (4:4.8.1-2ubuntu3) …
update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f95 (f95) in auto mode
Setting up manpages-dev (3.54-1ubuntu1) …
Processing triggers for libc-bin …

ubuntu@ip-172-31-43-203:~$ sudo apt-get install libconfig8 libconfig8-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libconfig8

ubuntu@ip-172-31-43-203:~$ sudo apt-get install openmpi-bin
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
blcr-util libcr0 libibverbs1 libopenmpi1.3 libtorque2 openmpi-checkpoint
openmpi-common
Suggested packages:
blcr-dkms
The following NEW packages will be installed:
blcr-util libcr0 libibverbs1 libopenmpi1.3 libtorque2 openmpi-bin
openmpi-checkpoint openmpi-common
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,845 kB of archives.
After this operation, 5,451 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe libcr0 amd64 0.8.5-2 [22.9 kB]
Get:2 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe blcr-util amd64 0.8.5-2 [28.5 kB]
Get:3 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe libtorque2 amd64 2.4.16+dfsg-1ubuntu1 [90.9 kB]
Get:4 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/main libibverbs1 amd64 1.1.6-1ubuntu2 [27.8 kB]
Get:5 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe libopenmpi1.3 amd64 1.4.5-1ubuntu2 [1,380 kB]
Get:6 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe openmpi-common all 1.4.5-1ubuntu2 [92.3 kB]
Get:7 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe openmpi-bin amd64 1.4.5-1ubuntu2 [163 kB]
Get:8 http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ saucy/universe openmpi-checkpoint amd64 1.4.5-1ubuntu2 [39.7 kB]
Fetched 1,845 kB in 0s (5,649 kB/s)
Selecting previously unselected package libcr0.
(Reading database … 56913 files and directories currently installed.)
Unpacking libcr0 (from …/libcr0_0.8.5-2_amd64.deb) …
Selecting previously unselected package blcr-util.
Unpacking blcr-util (from …/blcr-util_0.8.5-2_amd64.deb) …
Selecting previously unselected package libtorque2.
Unpacking libtorque2 (from …/libtorque2_2.4.16+dfsg-1ubuntu1_amd64.deb) …
Selecting previously unselected package libibverbs1.
Unpacking libibverbs1 (from …/libibverbs1_1.1.6-1ubuntu2_amd64.deb) …
Selecting previously unselected package libopenmpi1.3.
Unpacking libopenmpi1.3 (from …/libopenmpi1.3_1.4.5-1ubuntu2_amd64.deb) …
Selecting previously unselected package openmpi-common.
Unpacking openmpi-common (from …/openmpi-common_1.4.5-1ubuntu2_all.deb) …
Selecting previously unselected package openmpi-bin.
Unpacking openmpi-bin (from …/openmpi-bin_1.4.5-1ubuntu2_amd64.deb) …
Selecting previously unselected package openmpi-checkpoint.
Unpacking openmpi-checkpoint (from …/openmpi-checkpoint_1.4.5-1ubuntu2_amd64.deb) …
Processing triggers for man-db …
Setting up libcr0 (0.8.5-2) …
Setting up blcr-util (0.8.5-2) …
Setting up libtorque2 (2.4.16+dfsg-1ubuntu1) …
Setting up libibverbs1 (1.1.6-1ubuntu2) …
Setting up libopenmpi1.3 (1.4.5-1ubuntu2) …
Setting up openmpi-common (1.4.5-1ubuntu2) …
Setting up openmpi-bin (1.4.5-1ubuntu2) …
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
Setting up openmpi-checkpoint (1.4.5-1ubuntu2) …
Processing triggers for libc-bin …

ubuntu@ip-172-31-43-203:~$ sudo apt-get install libblacs-mpi1 libblacs-mpi1-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libblacs-mpi1-dev

ubuntu@ip-172-31-43-203:~$ sudo apt-get install libscalapack-mpi1 libscalapack-mpi1-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libscalapack-mpi1-dev

ubuntu@ip-172-31-43-203:~$ sudo ln -s /usr/lib/libscalapack-openmpi.a /usr/lib/libscalapack.a

ubuntu@ip-172-31-43-203:~$ pwd
/home/ubuntu

ubuntu@ip-172-31-43-203:~$ ls -la
total 32
drwxr-xr-x 5 ubuntu ubuntu 4096 Jan 23 01:48 .
drwxr-xr-x 3 root root 4096 Jan 23 01:39 ..
drwxr-xr-x 4 ubuntu ubuntu 4096 Jan 23 01:48 acousto-1.6
-rw-rr 1 ubuntu ubuntu 220 Mar 30 2013 .bash_logout
-rw-rr 1 ubuntu ubuntu 3637 Mar 30 2013 .bashrc
drwx-- 2 ubuntu ubuntu 4096 Jan 23 01:41 .cache
-rw-rr 1 ubuntu ubuntu 675 Mar 30 2013 .profile
drwx-- 2 ubuntu ubuntu 4096 Jan 23 01:39 .ssh

ubuntu@ip-172-31-43-203:~$ cd acousto-1.6/

ubuntu@ip-172-31-43-203:~/acousto-1.6$ ls
aclocal.m4 blender compile config.sub configure.ac depcomp INSTALL Makefile.am missing NEWS pi_head src
AUTHORS ChangeLog config.guess configure COPYING doc install-sh Makefile.in mysql php README

ubuntu@ip-172-31-43-203:~/acousto-1.6$ ./configure
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… gawk
checking whether make sets $(MAKE)… no
checking whether make supports nested variables… no
checking for gcc… gcc
checking whether the C compiler works… yes
checking for C compiler default output file name… a.out
checking for suffix of executables…
checking whether we are cross compiling… no
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… none
checking dependency style of gcc… none
checking whether gcc and cc understand -c and -o together… yes
checking whether make sets $(MAKE)… (cached) no
checking for robodoc… false
checking build system type… x86_64-unknown-linux-gnu
checking host system type… x86_64-unknown-linux-gnu
checking for mpicc… no
configure: error: cannot find mpicc compiler

ubuntu@ip-172-31-43-203:~/acousto-1.6$ sudo find / -iname "mpicc*"
/usr/share/openmpi/mpicc.openmpi-wrapper-data.txt
/usr/share/openmpi/mpicc-vt-wrapper-data.txt
/usr/share/openmpi/mpicc-wrapper-data.txt
/usr/share/openmpi/mpiCC-vt-wrapper-data.txt
/usr/share/openmpi/mpiCC-wrapper-data.txt
/usr/share/openmpi/mpiCC.openmpi-wrapper-data.txt
ubuntu@ip-172-31-43-203:~/acousto-1.6$

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License